summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 99e112c..f7c4be7 100644
--- a/default.nix
+++ b/default.nix
@@ -1,3 +1,15 @@
{ pkgs ? import <nixpkgs> {}
+, stdenv ? pkgs.llvmPackages_16.stdenv
+, clang-tools ? pkgs.clang-tools_16
+, forstio ? (import ((builtins.fetchGit {
+ url = "git@git.keldu.de:forstio/forstio";
+ ref = "dev";
+ }).outPath + "/default.nix"){
+ inherit stdenv;
+ inherit clang-tools;
+ }).forstio
}:
-pkgs.callPackage ./.nix/derivation.nix {}
+
+pkgs.callPackage ./.nix/derivation.nix {
+ inherit forstio;
+}