summaryrefslogtreecommitdiff
path: root/.nix
diff options
context:
space:
mode:
Diffstat (limited to '.nix')
-rw-r--r--.nix/derivation.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/.nix/derivation.nix b/.nix/derivation.nix
index a927e8d..fd41fc1 100644
--- a/.nix/derivation.nix
+++ b/.nix/derivation.nix
@@ -1,5 +1,6 @@
{ stdenv
, scons
+, forstio
}:
stdenv.mkDerivation {
pname = "icosahedrical_destruction";
@@ -9,5 +10,12 @@ stdenv.mkDerivation {
nativeBuildInputs = [
scons
+ forstio.core
];
+
+ doCheck = true;
+ checkPhase = ''
+ scons test
+ ./bin/tests
+ '';
}