summaryrefslogtreecommitdiff
path: root/.nix
diff options
context:
space:
mode:
Diffstat (limited to '.nix')
-rw-r--r--.nix/derivation.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/.nix/derivation.nix b/.nix/derivation.nix
new file mode 100644
index 0000000..e67f767
--- /dev/null
+++ b/.nix/derivation.nix
@@ -0,0 +1,31 @@
+{ lib
+, stdenv
+, scons
+, clang-tools
+, version
+, forstio
+}:
+
+stdenv.mkDerivation {
+ pname = "kelauth";
+ inherit version;
+ src = ./..;
+
+ enableParallelBuilding = true;
+
+ nativeBuildInputs = [
+ scons
+ clang-tools
+ ];
+
+ buildInputs = [
+ forstio.core
+ forstio.async
+ forstio.codec
+ forstio.io
+ forstio.remote
+ forstio.remote-fs
+ ];
+
+ outputs = ["out" "dev"];
+}