summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index f93b364..0ea5cdf 100644
--- a/default.nix
+++ b/default.nix
@@ -1,18 +1,28 @@
{ pkgs ? import <nixpkgs> {}
+, clang ? pkgs.clang_15
+, clang-tools ? pkgs.clang-tools_15
}:
let
forstio = (import ((builtins.fetchGit {
url = "git@git.keldu.de:forstio/forstio";
ref = "dev";
- }).outPath + "/default.nix"){}).forstio;
+ }).outPath + "/default.nix"){
+ inherit clang;
+ inherit clang-tools;
+ }).forstio;
kel-unit = (import ((builtins.fetchGit {
url = "git@git.keldu.de:libs/unit";
ref = "dev";
- }).outPath + "/default.nix"){});
+ }).outPath + "/default.nix"){
+ inherit clang;
+ inherit clang-tools;
+ });
in pkgs.callPackage ./.nix/derivation.nix {
inherit forstio;
inherit kel-unit;
+ inherit clang;
+ inherit clang-tools;
}