summaryrefslogtreecommitdiff
path: root/modules/codec-obj/.nix/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/codec-obj/.nix/derivation.nix')
-rw-r--r--modules/codec-obj/.nix/derivation.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/modules/codec-obj/.nix/derivation.nix b/modules/codec-obj/.nix/derivation.nix
new file mode 100644
index 0000000..1152cee
--- /dev/null
+++ b/modules/codec-obj/.nix/derivation.nix
@@ -0,0 +1,36 @@
+{ lib
+, stdenv
+, scons
+, clang-tools
+, version
+, forstio
+}:
+
+let
+
+in stdenv.mkDerivation {
+ pname = "forstio-codec-obj";
+ inherit version;
+ src = ./..;
+
+ enableParallelBuilding = true;
+
+ nativeBuildInputs = [
+ scons
+ clang-tools
+ ];
+
+ buildInputs = [
+ forstio.core
+ forstio.async
+ forstio.codec
+ ];
+
+ doCheck = true;
+ checkPhase = ''
+ scons test
+ ./bin/tests
+ '';
+
+ outputs = ["out" "dev"];
+}