summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix30
1 files changed, 19 insertions, 11 deletions
diff --git a/default.nix b/default.nix
index 20b00fc..7fb599d 100644
--- a/default.nix
+++ b/default.nix
@@ -24,6 +24,13 @@ in rec {
inherit stdenv;
inherit clang-tools;
};
+
+ crypto = pkgs.callPackage modules/crypto/.nix/derivation.nix {
+ inherit version;
+ inherit forstio;
+ inherit stdenv;
+ inherit clang-tools;
+ };
codec = pkgs.callPackage modules/codec/.nix/derivation.nix {
inherit version;
@@ -114,26 +121,27 @@ in rec {
};
};
- stable = pkgs.symlinkJoin {
- name = "forstio-${version}";
- paths = [
- forstio.core
- forstio.async
- forstio.codec
- forstio.codec-json
- forstio.codec-netcdf
- forstio.io
- forstio.io-tls
+ stable = pkgs.symlinkJoin {
+ name = "forstio-${version}";
+ paths = [
+ forstio.core
+ forstio.async
+ forstio.codec
+ forstio.codec-json
+ forstio.codec-netcdf
+ forstio.io
+ forstio.io-tls
+ forstio.remote
];
};
unstable = pkgs.symlinkJoin {
name = "forstio-unstable-${version}";
paths = [
- forstio.remote
forstio.remote-sycl
forstio.io_codec
forstio.thread
+ forstio.crypto
# forstio.codec-minecraft
];
};