summaryrefslogtreecommitdiff
path: root/docs/.nix
diff options
context:
space:
mode:
authorClaudius "keldu" Holeksa <mail@keldu.de>2024-05-23 17:23:25 +0200
committerClaudius "keldu" Holeksa <mail@keldu.de>2024-05-23 17:23:25 +0200
commit8b5c1e6a6cd5536d9414262c42452f8655658728 (patch)
tree29bf1540f93e33c64f63dc58b9bc2a90738310f7 /docs/.nix
parenteedd47efb3255f55216125cd3cd2ebdad3b8c1b6 (diff)
Got the docs to be generated
Diffstat (limited to 'docs/.nix')
-rw-r--r--docs/.nix/derivation.nix12
1 files changed, 8 insertions, 4 deletions
diff --git a/docs/.nix/derivation.nix b/docs/.nix/derivation.nix
index 929113d..a6dee7d 100644
--- a/docs/.nix/derivation.nix
+++ b/docs/.nix/derivation.nix
@@ -23,16 +23,20 @@ stdenvNoCC.mkDerivation {
buildPhase = ''
# C++ API generation
- doxygen docs/Doxygen.in
- python3 ${gasp.outPath}/bin/gasp.py xml --namespace duke > cpp_map.json
+ pushd docs
+ doxygen Doxygen.in
+ python3 ${gasp.outPath}/bin/gasp.py xml --namespace saw > cpp_map.json
# C++ and C template generation
mkdir -p source/cpp_api
- python3 ${gasp.outPath}/bin/make_rst.py --title="C++" -t ${gasp.outPath}/templates/rst -m cpp_map.json -o source/cpp_api
+ python3 ${gasp.outPath}/bin/make_rst.py --title="C++" -t ${gasp.outPath}/templates/rst -m cpp_map.json -o source/cpp_api
make html
+ popd
'';
installPhase = ''
mkdir -p $out
- mv docs/html $out/html
+ pushd docs
+ mv build/html $out/html
+ popd
'';
}