summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorClaudius "keldu" Holeksa <mail@keldu.de>2023-12-04 12:18:14 +0100
committerClaudius "keldu" Holeksa <mail@keldu.de>2023-12-04 12:18:14 +0100
commita14896f9ed209dd3f9597722e5a5697bd7dbf531 (patch)
tree089ca5cbbd206d1921f8f6b53292f5bc1902ca5c /default.nix
parent84ecdcbca9e55b1f57fbb832e12ff4fdbb86e7c9 (diff)
meta: Renamed folder containing source
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix25
1 files changed, 13 insertions, 12 deletions
diff --git a/default.nix b/default.nix
index 02ba8d0..f6e4913 100644
--- a/default.nix
+++ b/default.nix
@@ -7,82 +7,83 @@ let
version = "0.0.0";
in rec {
forstio = {
- core = pkgs.callPackage c++/core/.nix/derivation.nix {
+ core = pkgs.callPackage modules/core/.nix/derivation.nix {
inherit version;
inherit stdenv;
inherit clang-tools;
};
- test = pkgs.callPackage c++/test/.nix/derivation.nix {
+ test = pkgs.callPackage modules/test/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- async = pkgs.callPackage c++/async/.nix/derivation.nix {
+ async = pkgs.callPackage modules/async/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- codec = pkgs.callPackage c++/codec/.nix/derivation.nix {
+ codec = pkgs.callPackage modules/codec/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- codec-json = pkgs.callPackage c++/codec-json/.nix/derivation.nix {
+ codec-json = pkgs.callPackage modules/codec-json/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- codec-netcdf = pkgs.callPackage c++/codec-netcdf/.nix/derivation.nix {
+ codec-netcdf = pkgs.callPackage modules/codec-netcdf/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- io = pkgs.callPackage c++/io/.nix/derivation.nix {
+ io = pkgs.callPackage modules/io/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- io-tls = pkgs.callPackage c++/io-tls/.nix/derivation.nix {
+ io-tls = pkgs.callPackage modules/io-tls/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- window = pkgs.callPackage c++/window/.nix/derivation.nix {
+ window = pkgs.callPackage modules/window/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- window-opengl = pkgs.callPackage c++/window-opengl/.nix/derivation.nix {
+ window-opengl = pkgs.callPackage modules/window-opengl/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- tools = pkgs.callPackage c++/tools/.nix/derivation.nix {
+ tools = pkgs.callPackage modules/tools/.nix/derivation.nix {
inherit version;
inherit forstio;
inherit stdenv;
inherit clang-tools;
};
- };
+ };
+
forstio-test-cases = pkgs.callPackage tests/.nix/derivation.nix {
inherit version;