summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorClaudius "keldu" Holeksa <mail@keldu.de>2024-07-10 14:15:40 +0200
committerClaudius "keldu" Holeksa <mail@keldu.de>2024-07-10 14:15:40 +0200
commitff066b06a82f0ab330dab3ceb2d4b7132727f861 (patch)
tree1e6b8d0d85bbb7d5c441af36913d1da2ea2ef523 /default.nix
Initial commit
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..0f97734
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,32 @@
+{ pkgs ? import <nixpkgs> {}
+, stdenv ? pkgs.llvmPackages_16.stdenv
+, clang-tools ? pkgs.clang-tools_16
+, forstio ? (import ((builtins.fetchGit {
+ url = "git@git.keldu.de:forstio/forstio";
+ ref = "dev";
+ }).outPath + "/default.nix"){
+ inherit stdenv;
+ inherit clang-tools;
+ }).forstio
+}:
+
+let
+ version = "0.0.0";
+in
+rec {
+ forstio-examples = {
+ tools = pkgs.callPackage ./tools/.nix/derivation.nix {
+ inherit stdenv;
+ inherit clang-tools;
+ inherit version;
+ inherit forstio;
+ };
+ };
+
+ all = pkgs.symlinkJoin {
+ name = "forstio_examples-${version}";
+ paths = [
+ forstio-examples.tools
+ ];
+ };
+}