summaryrefslogtreecommitdiff
path: root/modules/remote-hip/.nix/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/remote-hip/.nix/derivation.nix')
-rw-r--r--modules/remote-hip/.nix/derivation.nix23
1 files changed, 4 insertions, 19 deletions
diff --git a/modules/remote-hip/.nix/derivation.nix b/modules/remote-hip/.nix/derivation.nix
index c63dd19..18d31c7 100644
--- a/modules/remote-hip/.nix/derivation.nix
+++ b/modules/remote-hip/.nix/derivation.nix
@@ -4,21 +4,17 @@
, clang-tools
, version
, forstio
-, openmp
, keldu
-, ocl-icd
-, lld_15
-, python3
-, bash
+, rocmPackages
-, build_examples ? "false"
+, build_examples ? "true"
, build_benchmarks ? "false"
}:
let
in stdenv.mkDerivation {
- pname = "forstio-remote-sycl";
+ pname = "forstio-remote-hip";
inherit version;
src = ./..;
@@ -26,7 +22,6 @@ in stdenv.mkDerivation {
nativeBuildInputs = [
clang-tools
- python3
scons
];
@@ -35,10 +30,6 @@ in stdenv.mkDerivation {
forstio.codec
forstio.async
forstio.remote
- keldu.adaptivecpp-dev
- ocl-icd
- openmp
- lld_15
];
buildPhase = ''
@@ -49,12 +40,6 @@ in stdenv.mkDerivation {
scons prefix=$out build_benchmarks=${build_benchmarks} build_examples=${build_examples} install
'';
- doCheck = true;
- checkPhase = ''
- export ACPP_APPDB_DIR=.
- scons test
- ./bin/tests
- '';
-
+ doCheck = false;
outputs = ["out" "dev"];
}