summaryrefslogtreecommitdiff
path: root/modules/remote-hip/.nix/derivation.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/remote-hip/.nix/derivation.nix')
-rw-r--r--modules/remote-hip/.nix/derivation.nix60
1 files changed, 60 insertions, 0 deletions
diff --git a/modules/remote-hip/.nix/derivation.nix b/modules/remote-hip/.nix/derivation.nix
new file mode 100644
index 0000000..c63dd19
--- /dev/null
+++ b/modules/remote-hip/.nix/derivation.nix
@@ -0,0 +1,60 @@
+{ lib
+, stdenv
+, scons
+, clang-tools
+, version
+, forstio
+, openmp
+, keldu
+, ocl-icd
+, lld_15
+, python3
+, bash
+
+, build_examples ? "false"
+, build_benchmarks ? "false"
+}:
+
+let
+
+in stdenv.mkDerivation {
+ pname = "forstio-remote-sycl";
+ inherit version;
+ src = ./..;
+
+ enableParallelBuilding = true;
+
+ nativeBuildInputs = [
+ clang-tools
+ python3
+ scons
+ ];
+
+ buildInputs = [
+ forstio.core
+ forstio.codec
+ forstio.async
+ forstio.remote
+ keldu.adaptivecpp-dev
+ ocl-icd
+ openmp
+ lld_15
+ ];
+
+ buildPhase = ''
+ scons build_benchmarks=${build_benchmarks} build_examples=${build_examples}
+ '';
+
+ installPhase = ''
+ scons prefix=$out build_benchmarks=${build_benchmarks} build_examples=${build_examples} install
+ '';
+
+ doCheck = true;
+ checkPhase = ''
+ export ACPP_APPDB_DIR=.
+ scons test
+ ./bin/tests
+ '';
+
+ outputs = ["out" "dev"];
+}