summaryrefslogtreecommitdiff
path: root/forstio/async/.nix
diff options
context:
space:
mode:
Diffstat (limited to 'forstio/async/.nix')
-rw-r--r--forstio/async/.nix/derivation.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/forstio/async/.nix/derivation.nix b/forstio/async/.nix/derivation.nix
new file mode 100644
index 0000000..8ceac08
--- /dev/null
+++ b/forstio/async/.nix/derivation.nix
@@ -0,0 +1,31 @@
+{ lib
+, stdenvNoCC
+, scons
+, clang
+, clang-tools
+, version
+, forstio
+}:
+
+let
+
+in stdenvNoCC.mkDerivation {
+ pname = "forstio-async";
+ inherit version;
+
+ src = ./..;
+
+ enableParallelBuilding = true;
+
+ nativeBuildInputs = [
+ scons
+ clang
+ clang-tools
+ ];
+
+ buildInputs = [
+ forstio.core
+ ];
+
+ outputs = ["out" "dev"];
+}