summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorClaudius "keldu" Holeksa <mail@keldu.de>2024-01-18 12:05:30 +0100
committerClaudius "keldu" Holeksa <mail@keldu.de>2024-01-18 12:05:30 +0100
commitf6ab3d97afe3525ebecc3603f78024e688b591c5 (patch)
treeb3216b0c91c2ad55725ee9c04eef1cdc8dfd7731 /default.nix
parentfec96c85a4d71f20d3de9791163a9a1f932c8e48 (diff)
nix: Adding default symlinkJoin target
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 004ef89..f1f95c4 100644
--- a/default.nix
+++ b/default.nix
@@ -74,5 +74,18 @@ in rec {
inherit stdenv;
inherit clang-tools;
};
- };
+ };
+
+ all = pkgs.symlinkJoin {
+ name = "forstio-all-${version}";
+ paths = [
+ forstio.core
+ forstio.async
+ forstio.codec
+ forstio.codec-json
+ forstio.codec-netcdf
+ forstio.io
+ forstio.io-tls
+ ];
+ };
}