summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorClaudius "keldu" Holeksa <mail@keldu.de>2024-04-11 18:24:47 +0200
committerClaudius "keldu" Holeksa <mail@keldu.de>2024-04-11 18:24:47 +0200
commit204aeb03daf43e73546077c8f72538ad3b6ac75b (patch)
tree91525622dd7dddb9586ad176b298b579cbdf6a16 /default.nix
parent5969e94c88f7db8cfe017190a27faf86b42b1a5f (diff)
codec, remote-opencl: Trying out opencl and ammending parts of codec for
it
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix25
1 files changed, 21 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index f6a372b..ef36e43 100644
--- a/default.nix
+++ b/default.nix
@@ -63,7 +63,14 @@ in rec {
inherit forstio;
inherit stdenv;
inherit clang-tools;
- };
+ };
+
+ remote-opencl = pkgs.callPackage modules/remote-opencl/.nix/derivation.nix {
+ inherit version;
+ inherit forstio;
+ inherit stdenv;
+ inherit clang-tools;
+ };
tools = pkgs.callPackage modules/tools/.nix/derivation.nix {
inherit version;
@@ -75,7 +82,7 @@ in rec {
};
};
- all = pkgs.symlinkJoin {
+ stable = pkgs.symlinkJoin {
name = "forstio-${version}";
paths = [
forstio.core
@@ -85,6 +92,16 @@ in rec {
forstio.codec-netcdf
forstio.io
forstio.io-tls
- ];
- };
+ ];
+ };
+
+ unstable = pkgs.symlinkJoin {
+ name = "forstio-unstable-${version}";
+ paths = [
+ forstio.remote-opencl
+ # forstio.codec-minecraft
+ ];
+ };
+
+
}