summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorClaudius "keldu" Holeksa <mail@keldu.de>2024-05-07 22:02:54 +0200
committerClaudius "keldu" Holeksa <mail@keldu.de>2024-05-07 22:02:54 +0200
commit0f8abfb2d48497e804d87e6e47a41c70e728901a (patch)
tree2bc49f336f0e4e2329ef5760295cb1952871d472 /default.nix
parentcd2a1ee7429c85b942229b6c91040aeccb02b571 (diff)
docs: Setting up doc generation
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix12
1 files changed, 11 insertions, 1 deletions
diff --git a/default.nix b/default.nix
index 4315710..7abf030 100644
--- a/default.nix
+++ b/default.nix
@@ -1,6 +1,11 @@
{ pkgs ? import <nixpkgs> {}
, stdenv ? pkgs.llvmPackages_17.stdenv
, clang-tools ? pkgs.clang-tools_17
+, gasp ? (import ((builtins.fetchGit {
+ url = "git@git.keldu.de:apps/gasp";
+ ref = "master";
+ }).outPath + "/default.nix"){
+ }).gasp
}:
let
@@ -81,7 +86,12 @@ in rec {
inherit clang-tools;
build_examples = "true";
- };
+ };
+
+ docs = pkgs.callPackage docs/.nix/derivation.nix {
+ inherit version;
+ inherit gasp;
+ };
};
stable = pkgs.symlinkJoin {